
How to perfectlymanage user access
for Google Ads accounts

Last Updated / Reviewed: Jan 10th, 2023
Execution Time: ~5 min to grant/request access

Goal: To properly and securely assign and revoke employees, freelancers, and
partners access to your Google Ads accounts.

Ideal Outcome: You have full control over who has access to your Google Ads
accounts, and have successfully assigned or revoked access to your employees or
partners.

Prerequisites or requirements:
● You need a Google Account;

Why this is important: If your Google Ads accounts aren’t properly accounted for and
managed, you can easily lose track who has access to what.

Where this is done: In the Google Ads platform.

When this is done: Every time you want to grant, request, or revoke access to your
Google Ads or Google Ads Manager accounts.

Who does this: The person responsible for managing access to Google Ads Accounts.



⛋ Understand user-access levels
1) Google Ads account access levels:

a) Email only - This user will not be able to sign in to your Google Ads
account.
i) E.g: If you want to share your Google Ads reports and alerts with

your other teammates without allowing them to actually access the
Ad Account.

b) Read-only - This user can sign in to your account, browse your
dashboard, campaigns, and assign read-only access to other users.
i) E.g: If you want to share your Google Ads data with your Content or

SEO team but do not want to allow them to make changes.
c) Standard - This user can perform almost all the actions that an

Administrator can except for managing access levels.
i) E.g: If you want to have an employee work on your Ad account,

managing your campaigns;
d) Administrative - This is the highest user-access level Google Ads has to

offer. Only assign this level to people you absolutely trust.
i) E.g: If you want to give access to your company’s Google Ads

account to a business partner.



2) Google Ads Manager user access levels:

a) Email only - This user will not be able to sign in to your Google Ads
Manager account.
i) E.g: If you want to share your Google Ads reports and alerts with

your other teammates without allowing them to actually access the
Ad Account.

b) Read-only - This user can sign in to your account, browse your
dashboard, campaigns, and assign read-only access to other users.
i) E.g: If you want to share your Google Ads data with your Content or

SEO team but do not want to allow them to make changes.

c) Standard - This user can perform almost all the actions that an
Administrator can except for managing access levels both on your Ads
Manager account and within the managed accounts.
i) E.g: If you want to have an employee work on your Ad account,

managing your campaigns;

d) Administrative - This is the highest user-access level Google Ads has to
offer. Only assign this level to people you absolutely trust.

Depending on whether the Ads Manager account is an Administrative
owner of the managed accounts this user might also be able to
downgrade other Administrators in the managed accounts or assign new
Administrators.

i) E.g: If you want to give access to your company’s Google Ads
account to a business partner.





Designing the best account structure for your
organization

Before we start, you need to understand what’s the difference between a Google
Ads Manager Account (formerly known as MCC Account), a Google Ads
Account, and a Google Account (it’s a confusing naming convention—we know)

Google Account - A Google account allows you to use the full suite of
Google services using a single login. If you have a Gmail account you
already have a Google Account.

Google Ads (non-manager) Account - A Google Ads account lets you
manage and create advertising campaigns on Google’s Advertising
network.

Google Ads Manager Account - A manager account is a Google Ads
account that lets you easily view and manage multiple Google Ads
accounts - including other manager accounts - from a single location.
(Source: Google)

This is how each of these will be represented in the diagrams below:

1. Does your business manage multiple Google Ads Accounts?
a. NO - Create a simple Google Ads account following SOP 014 (web

version)

a.1 - Do you have employees, freelancers, or agencies that you
will need to grant access?

- NO (it’s just you) - You don’t need user management—you
don’t need the rest of this SOP. This is how your account
structure will look like:

https://members.clickminded.com/sop/014/
https://members.clickminded.com/sop/014/


- YES (your team needs access to your ad account) - this is
how your account structure will look like:

b. YES (you’re managing multiple ad accounts) - You’ll need to use at least
one Google Ads Manager account to manage all your Ad Accounts.

b.1 - Do you need to restrict your employees or teammates
access to specific Ad Accounts?

- NO (it’s ok if every employee can access all Ad accounts in
my Ads Manager account) - Use a single Google Ads
Manager account with all the Google Ads Accounts your
business is managing.

This is how your structure will look like:



- YES (I want to control which Ad accounts my employees or
teammates can have access to) - you will need to create a
“Master” Google Ads Manager account and group Ad
Accounts using “Siloed” Ads Manager Accounts.

This is how your account structure will look like:



Master Google Ads Manager Account - This Google Ads
Manager Account will tie all your other siloed Google Ads
Manager Accounts.

Account Group #1, #2, #3, #X - These Google Ads
Manager Accounts will group the accounts that will be
shared among the different team members/employees
working on them.

E.g: Internal Employees, External Freelancers,
External Agencies—you will have to define what
makes sense for your specific case.



Use this template to design your own siloed structure.

Click here to edit this template according to your needs and
share it with your organization so everyone clearly
understands how Google Ads Accounts are structured.
(Remember: Click “File” → “Make a copy” to be able to edit)

Then, follow the next steps on this SOP to create your Ad
Manager accounts according to the structure you created.

https://members.clickminded.com/template/022/


Creating a Google AdsManager account

1. Open the Google Ads Manager account homepage, here.
2. Click “Create a manager account”;

3. Enter your account name, billing country, time zone and currency:
Note: You won’t be able to change the country, time zone, and currency later.

https://ads.google.com/home/tools/manager-accounts/


○ Name your account: Any name will do, but bear in mind your clients or
teammates will see this name when you request access to their Ad
Accounts.

4. Click “Submit”

5. You’re done. Click “Explore your account” to head to your ad account.



6. That’s it!

Request Access to a Google Ads Account fromaGoogle
AdsManager Account

⛋ Access given: Multiple available.

⛋ Typical scenario: An agency starts working with a client for the first time and
wants to access the client’s Google Ads account;

⛋ Who performs this action: The entity that wants access to the other’s Google
Ads account. (Typically this is the Agency that wants to request access to the
client’s Google Ads account);

⛋ Inputs needed: You will need your client’s (if you are an agency) Customer ID
(or the Customer ID of whichever account you want to link to your Google Ads
Manager Account. If you don’t have it yet, request it from your client or whoever
is currently managing the Ad account that you want to link.

1. Log into your Google Ads Manager account here.
2. On the sidebar, click “Accounts” → “+” →”Link Existing Account”

http://adwords.google.com


3. On the text box enter the Customer ID of the account that you would like to link to
your Google Ads Manager account → Click “Send Request”;

a. Note: If you don’t have this ID, ask the account owner to locate it under
their account.
i. To locate the Google Ads Account Customer ID:

1. When logged into the Ad Account that you want to give
access to, you will find your Customer ID on the top right
corner of your dashboard:

https://ads.google.com/


4. That’s it, you’ve just sent your access request, the owner of the account now has
30 days to accept your request before it expires;

Once the owner of the account confirms your request, you’ll find the account on
your “Accounts” section:

(Next Steps) Instructions for the invitee:
1. The invitee will receive an email prompting him to grant access to your

Google Ads Manager account:

Note: If no email was received, click here, and jump to step 5
below.

2. Open the email, and click “Accept Request”:

3. There will be a new notification for an account access request

https://adwords.google.com/aw/accountaccess/managers


4. Click “View”:

5. A request will be pending, click “Accept”:

6. Click “Grant Access”, and that’s it!

Grant access to your Google AdsManager account to
employees or freelancers so they canwork on the Ad
Accounts youmanage

⛋ Access given: Multiple access-levels.
○ Important: All Google Ads accounts linked to that Google Ads Manager

account will be available to the added user at the selected access level.

⛋ Typical scenario: An agency wants to assign an employee access to the
accounts that are managed by that Google Ads Manager account.

⛋ Who performs this action: The person that wants to grant access.
○ E.g: PPC Team leader grants access to the team’s MCC to a new member

of the team.

⛋ Inputs needed: You will need your employee’s / teammate’s email address;



1. Log into your Google Ads Manager account here.
2. On the header click “Tools” → “Account Access”

3. Click the blue ‘+’ button → Insert the details of the person you want to invite to
your MCC → “Send Invitation”;

a. Note: If you are unsure about the kind of access you should refer to the
first chapter of this SOP, section “2) Google Ads Manager user access
levels”.

4. Your request will be pending until your invitee accepts it:

Note: Once the person you invited accepts your invite you will see them
on your user list along with the assigned access level:

http://adwords.google.com


(Next Steps) Instructions for the invitee:
1. The invitee will receive an email prompting him to grant access to

your Google Ads Manager account:

Note: If no email was received, click here, and jump to step v.
2. Open the email, and click “Accept Request”:

3. Click “Continue” to confirm your email address:

4. That’s it! Your Google Account now has access to that Manager
Account.

Granting an Employee / Freelancer access to your
Google Ads account

1. Assess if the person you want to grant access is using a Google Ads Manager
account or a simple Google Account.

a. If they are using a Google Ads Manager account: Ask that person to
follow the first chapter of this SOP: “Request Access to a Google Ads
Account from a Google Ads Manager Account”, and send them your
Customer ID as well.

To locate the Google Ads Account Customer ID:
i. When logged in to the Ad Account that you want to give

access to, you will find your Customer ID on the top right
corner of your dashboard:

https://adwords.google.com/aw/accountaccess/managers
https://ads.google.com/


b. If they are using an individual Google Account: Proceed to step 2.

2. Log in to your Google Ads Manager account here.
3. On the header click “Tools” → “Access and security”

4. Click the blue ‘+’ button → Insert the details of the person you want to invite
(typically your employee’s email address) → “Send Invitation”;

a. Note: If you are unsure about the kind of access you should provide.
Refer to the first chapter of this SOP, section “1) Google Ads Account
access levels”.

http://adwords.google.com


5. Your request will be pending until your invitee accepts it:

Note: Once the person you invited accepts your invite you will see them
on your user list along with the assigned access level:



(Next Steps) Instructions for the invitee:
5. The invitee will receive an email prompting him to grant access to

your Google Ads Manager account:

Note: If no email was received, click here, and jump to step v.
6. Open the email, and click “Accept Request”:

7. Click “Continue” to confirm your email address:

8. That’s it! Your Google Account now has access to that Manager
Account.

𝥷 Revoking access to your Google Ads or Google Ads
Manager account

1. Log in to your Google Ads account.
a. Note: Make sure you have user-management access level. You can check

the respective user-levels on the first chapter of this SOP.

2. On the header click “Tools” → Account Access
a. Note: Alternatively you can click here.

https://adwords.google.com/aw/accountaccess/managers
https://docs.google.com/document/d/1iCqkYmwF6lracdlSb4VWXOZS-FZE4JE48jLbuEewmY4/edit#bookmark=kix.vyzap3l7jldx
https://adwords.google.com/aw/accountaccess/users


3. On the top, select “Users” if you are removing an employee or partner that is not
using a Google Ads Manager account, or “Managers” if you are removing one
that is using a Google Ads Manager account.

a. Note: If you are unsure just check both tabs.

4. Locate the employee or partner that you want to remove → click “Remove
access”

5. Confirm by clicking “Remove access” once again.

6. That’s all!

⛋ Unlinking a Google Ads or Google AdsManager account
fromyour Google AdsManager account

1. Log into your Google Ads Manager account.
a. Note: Make sure you have administrative access level. You can check the

respective user-levels on the first chapter of this SOP.

2. On the sidebar click “Accounts” → Click the “Management” tab → Locate and
‘tick’ the account you want to unlink → Click “Edit” → Click “Unlink”

https://adwords.google.com/


3. Confirm by clicking “Unlink”:

4. That’s it! You’ll see a success message on the bottom of your screen:


